Followup: Installing Ubuntu from Windows

Ok, so I got unetbootin installed and rebooted.  But I’m hit with a Windows error message saying it can’t boot.

I’ve edited boot.ini thusly:

9c9
< F:\ubnldr.mbr="UNetbootin"
---
> multi(0)disk(0)rdisk(0)partition(2)\ubnldr.mbr="UNetbootin"
9c9< F:\ubnldr.mbr="UNetbootin"---> multi(0)disk(0)rdisk(0)partition(2)\ubnldr.mbr="UNetbootin"

This -should- allow me to boot into ubuntu.  Fingers crossed.  Will edit if not.

EDIT1: This did not work.  Windows’ bootloader thought unetbootin was a Windows operating system, and was therefore expecting files which are clearly not present.  I’m therefore re-installing unetbootin in the vain hope that it will work.  Will edit again when it doesn’t.

EDIT2: This did not work.  Windows’ bootloader STILL thinks unetbootin is a Windows operating system despite several variations in my installation procedure.  I think the only way to convince my computer otherwise is to take the decision out of Windows’ hands.  That requires waiting for Mike to wake up and give me a blank CD though (his LiveCD of Ubuntu is 64bit and my processor is somewhat deficient in bits.  It only has 32, bless it…)  Another edit will follow with tales of my success once I have a CD in my hands…

EDIT3: Day 2 of using Ubuntu again and I can honestly say I couldn’t be happier.  Windows XP is probably never going to see the light of day again.  I’m home!!! SO happy!

Installing Ubuntu from Windows

I recently ran into the problem of using wubi.exe (Ubuntu’s Windows installer) to install Ubuntu 10.10 and hitting a “try (hd0,0): EXT2:” hang.  Information on the internet is sporadic and confusing at best so I thought I’d post a run-down of what steps I took, what worked and what didn’t.

Note that this whole procedure would’ve been a lot easier if I had a blank CD or a LiveCD of Ubuntu to hand, but I don’t, so never mind.

Ok, so when I hit the error I gave it time to complete what it was doing, it was definitely hung.  So I rebooted back into Windows and tried a different .iso image.  Same issue.  So I tried a different wubi.exe (specifically, the one on the 10.10 i386 iso rather than the one you get if you choose to download it from ubuntu.com).  Same issue.  At this point I ran around the net in circles for about an hour getting nowhere fast but eventually stumbling upon some people reporting the issue affecting EasyBCD.  So I looked into what exactly EasyBCD was, it turns out it’s a way to modify the Windows Vista/7 bootloader.  Since the SP3 bootloader is nigh-identical to the Vista/7 one, I thought EasyBCD might help.  Unfortunately, it’s only superficially identical, and despite following a “howto use EasyBCD on Windows XP” tutorial, I managed to completely remove the Windows XP bootloader menu, replacing it with a black screen that flashes for a second then boots into windows.  Great.  So now I can’t even -try- to boot wubi.

It was at this point I hit the ‘net again, and after another hour or two of circular google-forum-google work I eventually hit upon “Unetbootin”.  I knew of Unetbootin before but only very vaguely, had once used it to try out a few OSes.  It turns out that Unetbootin can mimick wubi, almost, but in a much more sane way.  What Unetbootin does is perform a ‘frugal install’, in other words using your hard disk as a LiveCD.  Sort of a LiveHDD idea.  Perfect!  Once you’re in the Live environment, performing an install to an already-prepped Ubuntu partition (which I just so happen to have) is trivial.  I’ll post a follow-up detailing my success with this (it’s currently halfway through installing).

Check back later!